Configurazione di base di un router Cisco

Passi principali per la configurazione

I principali passi necessari alla configurazione completa dei router Cisco può essere così schematizzata:

  • configurazione di base: parametri di sistema, password

  • configurazione delle interfacce: configurazione a basso livello, imbustamento, velocità, indirizzi

  • configurazione del routing: route di default, attivazione dell’instradamento (forwarding), parametri propri di ciascun processo di routing (OSPF, …)

  • configurazione avanzata: access lists, etc

Accesso e configurazione di base

L’accesso al router può avvenire via rete (telnet) oppure collegando un terminale (o un PC) alla console (fisicamente è una porta seriale classica) del router. Nel primo caso è possibile la gestione da remoto; nel secondo caso è necessario essere in locale (oppure collegato al router tramite modem).
Alla configurazione si accede con due modalità:

  • user mode – Accesso consentito per controllare lo stato del router. In questa modalità non è possibile manipolare la configurazione.

  • privileged mode -Accesso consentito per la modifica della configurazione.

Accesso via telnet

Accesso via console

telnet indirizzo_ip

Sono ammessi gli indirizzi IP di tutte le interfacce attive non unnumbered del router

Dopo aver collegato un terminale VT100 (oppure un PC mediante un cavo seriale) è possibile inserire direttamente i comandi del sistema operativo.

Parametri per l’emulazione terminale:

  • 9600 bps
  • 8 bit
  • No parity
  • Stop Bit 1
  • Flow Control Hardware

Richiede normalmente due password di accesso:

  • quella per l’accesso al router (user mode)
  • (privileged mode)

    quella per l’accesso alla modalità privilegiata

Richiede una sola password di accesso, quella per l’accesso alla modalità privilegiata.

L’accesso in locale è obbligatorio nella fase di configurazione iniziale del router; successivamente è possibile utilizzare anche l’accesso telnet (se il router è raggiungibile).

Procedura per l’accesso (via telnet):

telnet indirizzo_ip

  • viene richiesta la password di accesso
  • si entra in modalità utente

Per entrare in modalità privilegiata:

enable

  • (il prompt cambia e ci si trova in modalità di configurazione “#” – pound sign)

    viene richiesta la password di amministrazione

Per entrare in modalità di configurazione:

configure terminal (abbreviato: conf t)

(oppure configure network

per la configurazione via rete)

Procedura per l’accesso (via terminale): uguale a quella via telnet, tranne per il fatto che di default ci si ritrova direttamente in modalità utente (si risparmia una password).

Comandi principali a router spoglio

 > enable

Consente l’accesso alla modalità priivilegiata (richiede la password).

 > erase startup_config

Cancella la configurazione della FLASH.

 > configure terminal

Entra in configurazione; la configurazione è fatta da terminale (non da rete).

 > hostname Cisco1

Assegnazione del nome al router.

 > enable password passwdena

Abilitazione (e configurazione) della password del router locale (quella richiesta alla digitazione del comando enable).

 # line vty 0 4

Configurazione dei terminali virtuali: il primo numero dopo il VTY indica il numero del primo terminale virtuale; il secondo indica il numero dell’ultimo terminale virtuale (in questo .caso è stata configurata la possibilità di 5 accessi contemporanei al router)

 # login

Imposizione del login nell’accesso via telnet (ma non impone una password).

 # password passwdtelnet

Abilitazione (e configurazione) della password di accesso al router via telnet.

 # exit

Esce dalla modalità di configurazione dei terminali virtuali.

 # exit

Esce dalla modalità di configurazione.

Altri comandi fondamentali (attivabili solo in modalità enable)

write [memory]

Salva nella FLASH la configurazione attiva.

write network

Salva su un server TFTP la configurazione attiva.

reload

Effettua il reboot del router.

write terminal

show running-config

Comandi equivalenti; visualizzano su monitor l’attuale configurazione del router (quella in RAM).

show configuration

Visualizza su monitor la configurazione salvata su FLASH.

NOTA: quando viene visualizzata una configurazione, vengono riportate solo le opzioni che non sono al valore standard.

Controllo e debugging

I principali comandi di utilità, controllo e debugging sono solitamente disponibili solo in modalità privilegiata

show comando

Visualizza i parametri relativi a comando.

show ?

Elenca ciò che è possibile visualizzare.

term mon

term no mon

(per la sua disattivazione)

Attiva il debuging sul monitor (necessario solo via telnet, per attivare l’output su terminale locale e non sulla console del router).

debug comando

Per attivare il debug su una funzione specifica.

debug ?

Mostra le attività su cui il debugging può essere attivato.

ping indirizzo

Controlla la raggiungibilità di indirizzo.

NOTA: non raggiungibilità non implica automaticamente la mancanza di una route per raggiungere la destinazione, ma più anche essere l’eventuale mancanza di una route per il ritorno.

trace indirizzo

Visualizza il percorso verso la destinazione; nel caso di più percorsi, li visualizza tutti.

[telnet] indirizzo

Apre un terminale virtuale con la destinazione.

Configurazione e controllo delle interfacce

L’IOS assegna ad ogni interfaccia fisica di rete un identificativo univoco all’interno del sistema. Questo identificativo è formato dal loro nome “tecnologico” più un identificativo numerico (quindi si troveranno Ethernet0, Ethernet1, Serial 0, Serial1) in ordine crescente.

Da questo punto in poi si seguiranno le seguenti regole:

  • i comandi, eccetto quando chiaramente specificato, saranno comandi disponibili solamente da in modalità configurazione (o da un suo sottomenu)

  • a questa regola fanno eccezione i comandi inizianti per “show”, i quali sono disponibili esclusivamente in modalità “enable”.

Comandi fondamentali

ip subnet-zero

Abilita l’uso della subnet zero sulle interfacce e sulle routing updates. In mancanza di questo comando non è possibile configurare una rete come 130.192.1.0 netmask 255.255.255.252, ma solo 130.192.1.4.

ip address indirizzo maschera [secondary]

Assegna all’interfaccia l’indirizzo indirizzo. Questo comando permette l’entrata nel sottomenu di configurazione delle interfacce. L’opzione secondary indica che l’indirizzo è secondario.

description descrizione_interfaccia

Assegna una stringa letterale per la descrizione dell’interfaccia.

shutdown

Disabilita il funzionamento di quell’interfaccia (può essere utilizzato ad esempio dalle interfacce ISDN per forzare la terminazione della chiamata corrente); per riattivare l’interfaccia è necessario digitare no shutdown.

mtu valore

Definisce una MTU diversa rispetto a quella standard.

ip proxy arp

Abilita il proxy arp su quell’interfaccia.

show interface [nome]

Visualizza gli attuali dati relativi alle interfacce del router; se viene specificato nome, vengono visualizzati solamente i dati relativi a quell’interfaccia.

encapsulation ppp | hdlc

(solo link seriali e ISDN)

Definisce il tipo di protocollo sul link fisico. HDLC è una versione proprietaria CISCO (permette il multiprotocol), per cui è necessario usare il PPP quando è necessaria l’interoperabilità con altri costruttori. HDLC non prevede autenticazione.

clockrate valore

(solo su link seriali)

Definisce la velocità del link seriale (non usato per ISDN). Il clock rate va abilitato solo nel caso di connessione di router con cavo DCE/DTE, e solo sul router che dispone del lato DCE. In un normale collegamento il clock viene fornito dal modem e non dall’interfaccia.

ppp authentication {chap | pap}

Abilita l’uso dell’autenticazione su quel particolare link PPP. Per autenticarsi dall’altra estremità del link, il router usa come nome utente il proprio nome. Entrambi i protocolli di autenticazione possono essere contemporaneamente attivi, e vengono tentati nell’ordine in cui compaiono.

username name password secret passwd

Associa password a nomi, ed è un comando di configurazione globale (non di interfaccia). Il router usa come password quella associata al proprio nome; secret è un numero che specifica il tipo di cifratura per la password.

Esempi di configurazione

interface Ethernet1

ip address 128.99.3.8 255.255.255.0

ip addr 128.99.4.9 255.255.255.0 sec

no shutdown

exit

interface Bri0

ip address 128.99.9.2 255.255.255.0

no shutdown

exit

interface Serial0

ip address 128.99.10.3 255.255.255.0

clockrate 2000000

encapsulation ppp

no shutdown

end

Configurazione ISDN

I passi fondamentali per la configurazione di ISDN sono:

  • configurazione del tipo di ISDN

  • configurazione delle interfacce

  • configurazione dei gruppi

  • configurazione delle eventuali access-list

Comandi principali

isdn switch-type basic-net3

Imposta il tipo di switch con cui operare (euro-isdn).

Nelle ultime versioni di IOS questo comando è diventato comando di interfaccia (prima era globale), per cui diventa possibile avere interfacce ISDN attaccate a diversi tipi di centralini (con segnalazione diversa).

show isdn status

Visualizza lo stato delle connessione; la voce “layer 3” indica se la chiamata è in piedi oppure no.

dialer string num

Utilizza sempre il numero num per aprire una chiamata.

Questo comando (oppure in alternativa quello successivo) è sempre obbligatorio.

dialer map prot indir [name name] num

Permette di definire più numeri a cui instradare la chiamata a seconda del pacchetto che si presenta all’interfaccia, con il significato “per instradare un pacchetto del protocollo prot verso il next-hop indir apri una connessione con il numero ISDN num”. Il pacchetto deve essere di interesse per l’interfaccia; inoltre la corrispondenza tra indir e num è utilizzata anche in fase di accettazione delle chiamate (“Se devo raggiungere l’indirizzo indir devo comporre il numero num” ma anche: “Riconosco come pacchetti validi provenienti da indir solo quelli che provengono da una connessione col numero num”).

dialer-group num

Indica il tipo di filtro da applicare ai pacchetti che attraversano l’interfaccia (specifica il gruppo di accesso cui appartiene l’interfaccia); è un comando obbligatorio.

dialer idle-timeout sec

Tempo dopo il quale, se non viene rilevato traffico su quell’interfaccia, il collegamento viene disattivato. Se non specificato viene adottato quello standard (120 sec).

isdn answer1 num

Indica che può accettare chiamate provenienti dal numero ISDN num; è usato per il controllo accessi.

dialer-list num protocol proto [permit | deny]

Definisce la dialer-list numero num, abilitando (permit) o negando (deny) la chiamata per tutti i pacchetti del protocollo proto. E’ un comando di configurazione globale.

dialer-list num protocol proto list num_list

Abbina la dialer-list numero num (che vale solamente per un certo protocollo proto) all’access-list num_list.

access-list num {permit | deny} proto

source [source-mask]

Crea la lista di accesso numero num:

  • permit: identifica pacchetti che causeranno l’instaurazione di una connessione

  • deny: identifica pacchetti che non causeranno l’instaurazione di una connessione

  • source-mask: i bit a 1 indicano le posizioni che si vogliono ignorare (l’opposto della netmask IP)

Esempio: permettere l’ingresso e l’uscita a tutti i pacchetti IP:

access-list 101 permit ip any any

access-list num {permit | deny} proto

source source-mask dest dest-mask

Analoga alla versione precedente, ma con sintassi estesa; controlla i pacchetti in base agli indirizzi sorgente e destinazione degli stessi.

Esempio: disabilitare l’inoltro dei pacchetti IGRP provenienti da qualunque sorgente e diretti verso qualunque destinazione:

access-list 101 deny igrp 0.0.0.0

255.255.255.255 0.0.0.0 255.255.255.255

show dialer

Visualizza le informazioni sui dialers attivati; il campo “last called” indica il tempo trascorso da quando l’interfaccia indicata ha effettuato una chiamata ISDN.

show dialer interface

Visualizza le informazioni sui dialer profiles attivati.

show dialer map

Visualizza i dialer map correnti, l’indirizzo del next hop a cui instradare la chiamata, username utilizzati, le interfacce sulle quali sono configurati.

clear dialer

Azzera i valori delle statistiche.

Configurazione dei gruppi e delle Access Lists

Ogni interfaccia dial-up deve appartenere ad almeno un gruppo logico (dialer-group) che identifica una serie di interfacce con determinate caratteristiche (ad esempio quelle di sicurezza) comuni. Un gruppo di esempio può essere “chiamate dial-up verso la sede centrale”. Se l’interfaccia appartiene a più gruppi (dialer_list), sarà possibile specificare in ognuno di essi diverse politiche di accesso per un ben determinato protocollo (IP, IPX, …).

Dopo aver specificato l’appartenenza di ogni interfaccia ad almeno un gruppo, è necessario definire le caratteristiche di ogni gruppo, ossia definire in base a che pacchetti l’interfaccia è abilitata a fare la chiamata verso la sede remota.

Nell’esempio seguente la chiamata viene instradata se ci sono dei pacchetti IP da instradare:

Interface BRI0

dialer-group 1

exit

dialer-list 1 protocol ip permit

La dialer-list non permette tuttavia di definire politiche sofisticate in quanto permette di scegliere solo il protocollo ma non altri dettagli (ad es. abilitare alla chiamata solo i pacchetti che arrivano da una certa sottorete). Per politiche più complesse la dialer-list viene associata ad una access-list, permettendo di abbinare quel particolare gruppo ad una serie di politiche estese definite da queste ultime strutture. Per una data dialer-list e un dato protocollo è possibile una sola access-list, la quale può essere composta da più righe rendendo possibili diverse politiche contemporaneamente.

L’access-list specificherà in dettaglio le politiche che daranno luogo all’instaurazione della chiamata.

Esempio completo di configurazione

conf t

Entra in modalità configurazione.

isdn switch-type basic-net3

Definisce il tipo di ISDN utilizzato.

interface BRI0

Entra in configurazione interfaccia.

  ip address 130.192.27.33

255.255.255.240

Definisce l’indirizzo IP.

  encapsulation ppp

Definisce il livello 2.

  dialer map ip 130.192.27.34 5178046

Abbina il numero telefonico da chiamare con l’indirizzo IP remoto.

  dialer-group 1

Assegna l’interfaccia al gruppo numero 1.

  exit

Esce dalla configurazione dell’interfaccia.

ip route 130.192.27.0 255.255.255.0

130.192.27.34

Configura le route statiche necessarie per raggiungere il resto della rete attraverso ISDN.

dialer-list 1 protocol ip list 101

Dialer-list: definisce come “interessanti” tutti i pacchetti IP, quindi associa il dialer-group 1 alla access-list 101 per un miglior raffinamento della politica di accesso.

access-list 101 permit ip any any

Filtro (numero 101) da applicare ai pacchetti. In questo caso, una access-list così semplice è superflua in quanto sarebbe bastato il semplice comando dialer-list. Una access list “migliore” potrebbe essere:

access-list 101 permit ip 126.0.0.0 0.255.255.255

128.16.64.0 0.0.0.255

access-list 101 deny igrp 0.0.0.0 255.255.255.255

0.0.0.0 255.255.255.255

dove si accettano in ingresso i pacchetti della rete 126.x diretti verso la 128.16.64.x, purché questi pacchetti non siano IGRP.

end

Termina la configurazione corrente.

Configurazione di backup, trabocco

E’ opportuno evidenziare come il backup (in generale) si può ottenere anche su un’altra interfaccia che non sia una dial-up, anche se tali interfacce sono le più utilizzate.

backup interface tipo numero

Comando, dato sull’interfaccia primaria, che identifica l’interfaccia tipo numero come backup.

backup delay {abil {disabil | never}}

L’interfaccia di backup è abilitata dopo abil secondi che l’interfaccia primaria non è più attiva, ed è disabilitata dopo disabil secondi che l’interfaccia primaria è nuovamente attiva. Questo comando è dato sull’interfaccia primaria.

backup load {abil {disabil | never}}

L’interfaccia di backup è abilitata quando il traffico sull’interfaccia primaria è superiore ad abil % della capacità del canale primario, ed è disabilitata quando il traffico aggregato è inferiore a disabil % la capacità del canale primario. Questo comando è dato per l’interfaccia primaria; il load viene calcolato come il carico medio sul link in un intervallo sufficientemente lungo (qualche minuto).

Esempio: attivare il backup quanto il carico supera il 60% della capacità dell’interfaccia Serial0; la disattivazione avviene quando il carico aggregato (Serial0 + Serial1) è minore del 5% della sola capacità dell’interfaccia primaria (Serial0):

interface Serial0

backup load 60 5

backup interface serial1

Esempio di configurazione

interface Serial0

Entra in configurazione della serial0.

  backup delay 0 0

Configura il tempo di intervento del backup: l’interfaccia di backup si attiva non appena l’interfaccia primaria cade, e si disattiva non appena l’interfaccia prima ritorna attiva.

  backup interface BRI0

Definisce la BRI0 come interfaccia di backup.

  ip address 130.192.27.17 255.255.255.240

Configura l’indirizzo IP.

  encapsulation ppp

Definisce il protocollo di livello 2.

  exit

Termina la configurazione dell’interfaccia Serial0.

interface BRI0

Entra in configurazione della ISDN.

  ip address 130.192.27.33 255.255.255.240

Configura l’indirizzo IP.

  encapsulation ppp

Definisce il protocollo di livello 2.

  isdn answer1 115180136

Definisce il numero da cui è in grado di accettare le chiamate (non necessario sul chiamante).

NOTA: siccome non è definito a priori quale sarà il primo router ad effettuare la chiamata di backup (in generale sarà il primo che riceverà un pacchetto da recapitare all’altro capo della connessione), è opportuno che i due router affacciati siano configurati in modo speculare per quanto riguarda i comandi isdn answer1 e dialer map.

  dialer map ip 130.192.27.34 5180135

Definisce il numero telefonico e l’indirizzo dell’altro capo del link.

  dialer-group 1

Definisce l’appartenza dell’interfaccia al gruppo 1.

  exit

Termina la configurazione dell’interfaccia BRI0.

ip route 130.192.0.0 255.255.0.0 130.192.27.34 2

Definisce la route secondaria (a costo maggiore) verso la destinazione in modo da utilizzare il collegamento ISDN.

NOTA: il comando backup imposta l’interfaccia di backup ed effettua la chiamata, ma non sposta automaticamente le route sulla nuova interfaccia in quanto l’interfaccia ISDN ha un indirizzo IP diverso e quindi la precedente route non è più valida. Il costo superiore per quanto riguarda questa route evita che in condizioni normali i pacchetti transitino su questo link.

ip route 130.192.0.0 255.255.0.0 130.192.27.18

Definisce la route primaria verso la destinazione in modo da utilizzare il collegamento seriale.

NOTA: questa route viene automaticamente eliminata nel momento in cui il link seriale si interrompe.

dialer-list 1 protocol ip list 101

Abbina il gruppo 1 con l’access list 101.

access-list 101 permit ip any any

Definisce l’access list 101.

end

Termina la configurazione.

Configurazione dei Dialer Profiles (o Rotary groups)

I dialer profiles consentono il mapping della configurazione di una interfaccia fittizia ad un insieme di interfacce fisiche, consentendo ad un numero limitato di interfacce fisiche di chiamare molte destinazioni al seconda del bisogno. Il problema del mapping statico (senza dialer profiles) è schematizzato dal seguente esempio:

  • si supponga che le interfacce A, B, C definiscano come backup rispettivamente D, E, E

  • se cadono contemporaneamente B e C una delle due non potrà usufruire del backup, anche se una linea (D) è libera

Con l’attivazione dei dialer profiles, invece:

  • le interfacce A, B, C definiranno come backup rispettivamente F, G, H, che sono interfacce fittizie

  • F,G,H utilizzeranno, per le chiamate, uno stesso insieme (pool) di interfacce fisiche D, E

  • D, E sono configurate ad appartenere allo stesso pool di chiamata (pool-member)

  • se cadono contemporaneamente B e C verranno automaticamente attivate le interfacce G, H

  • queste inoltreranno la richiesta sulle prime due interfacce fisiche appartenenti a quel pool (D, E)

La configurazione avviene operativamente con i seguenti passi:

  • si definisce una interfaccia logica (dialer) che implementa il rotary-group

  • si definiscono quali sono le interfacce fisiche che appartengono a quel rotary group

  • si configurano le interfacce opportune a sfruttare il backup se necessario

  • le interfacce che necessitano di avere un backup specificheranno come backup interface non le interfacce fisiche (BRI0, …) ma quelle logiche (Dialer)

Nel caso in cui il rotary group venga utilizzato per la trasmissione di protocolli di routing potrebbe essere necessario disabilitare lo split horizon e la validazione dell’indirizzo sorgente:

router rip

no validate-update-source

Esempio di configurazione

interface dialer0

Definisce una prima Dialer Interface.

  ip unnumbered loopback0

Specifica un indirizzo di loopback IP unnumbered.

  encapsulation ppp

Definisce l’encapsulation PPP.

  dialer remote-name Remote0

CHAP autentication name del router remoto.

  dialer pool 1

Specifica il pool number. Nel momento in cui questa interfaccia dovesse attivarsi per fare una chiamata, verrà utilizzata una delle interfacce fisiche associate a questo pool (in questo caso BRI0).

  dialer string 5551212

Numero di telefono.

  dialer-group 1

Assegna l’interfaccia ad un dialer group.

  exit

Termina la configurazione di questa interfaccia.

interface dialer1

Definisce una seconda Dialer Interface.

  ip unnumbered loopback0

Specifica un indirizzo di loopback IP unnumbered.

  encapsulation ppp

Definisce l’encapsulation PPP.

  dialer remote-name Remote1

CHAP autentication name del router remoto.

  dialer pool 1

Specifica il pool number. Nel momento in cui questa interfaccia dovesse attivarsi per fare una chiamata, verrà utilizzata una delle interfacce fisiche associate a questo pool (in questo caso BRI0).

  dialer string 5551234

Numero di telefono.

  dialer-group 1

Assegna l’interfaccia ad un dialer group.

 exit

Termina la configurazione di questa interfaccia.

interface serial0

Specifica la Serial0.

  ip unnumbered loopback0

Specifica un indirizzo di loopback IP unnumbered.

  backup interface dialer0

Definisce la Dialer0 come interfaccia di backup.

  backup delay 5 10

Specifica i parametri di attivazione / disattivazione del backup.

  exit

Termina la configurazione di questa interfaccia.

interface serial1

Specifica la Serial1.

  ip unnumbered loopback0

Specifica un indirizzo di loopback IP unnumbered.

  backup interface dialer1

Definisce la Dialer1 come interfaccia di backup.

  backup delay 5 10

Specifica i parametri di attivazione / disattivazione del backup.

  exit

Termina la configurazione di questa interfaccia.

interface bri0

Specifica l’interfaccia ISDN.

  encapsulation ppp

Definisce l’encapsulation PPP.

  dialer pool-member 1

Definisce l’interfaccia come appartenente al pool “1”. Questa interfaccia verrà usata da Dialer0 e Dialer1 per far partire la chiamata.

In alcune versioni di IOS il comando è sostituito da:

dialer rotary-group num

  ppp authentication chap

Definisce l’autenticazione CHAP.

  exit

Termina la configurazione di questa interfaccia.

Per rendere funzionante questo esempio è necessario, al solito, configurare successivamente le dialer-list e le access-list.

Configurazione e controllo del routing

Comandi fondamentali

show ip route

Mostra la routing table del protocollo IP.

clear ip route

{network [mask] | *}

[Modalità privilegiata] Permette la cancellazione di una o più route che si suppongono non più valide. Questo comando non prmette la cancellazione delle route statiche.

show ip proto

Visualizza lo stato di ogni protocollo di routing attivo (tempistiche, parametri (es per EIGRP), redistribuzioni, …).

ip routing

Abilita il router ad instradare pacchetti IP (processo di forwarding).

NOTA: è un comando usato in forma negata (no ip routing) per cancellare completamente la precedente configurazione di routing, lasciando il router spoglio. A questo punto si riabilita il routing e si procede alla sua nuova configurazione.

ip classless

Nel momento in cui il router riceve un pacchetto per cui non ha una route specifica (e nemmeno la default route), usa la migliore supernet route possibile.

Route statiche, di default, redistribuzione

ip route indirizzo maschera router [distanza]

I pacchetti destinati alle reti comprese nel range (indirizzo, maschera) devono essere instradati verso router, che deve essere:

  • in una sottorete direttamente collegata a una delle interfacce

  • una porta del router corrente nel caso in cui l’interfaccia sia unnumbered

Esempio:

interface Ethernet1

ip address 128.99.3.8 255.255.255.0

exit

interface serial0

ip unnumbered loopback0

exit

ip route 130.192.0.0 255.255.0.0 128.99.3.2

ip route 130.192.4.0 255.255.255.0 128.99.3.9

ip route 198.205.2.0 255.255.255.0 serial0

NOTA: la route può essere sostituita da una appresa dinamicamente e avente distanza inferiore.

no ip route indirizzo maschera router

Elimina la route statica.

ip default-network indirizzo

Configura una route di default.

E’ immessa da uno smart router, il quale normalmente conosce le route per qualsiasi indirizzo, e diffonde la route di default tramite i protocolli di routing. La modalità con cui questa è propagata dipende dal protocollo di routing:

  • RIP annuncia 0.0.0.0 0.0.0.0

  • IGRP annuncia indirizzo indicandola come route esterna e candidata route di default.

redistribute protocollo [id]

Distribuisce nel dominio del router in questione le informazioni raccolte tramite il protocollo protocollo; è un sottocomando della modalità router

  • id è necessario per discriminare tra più processi dello stesso protocollo (es. EIGRP)

Esempio:

router rip

redistribute igrp 148

In questo caso il processo di router RIP distribuisce tutte le route apprese da IGRP, ma non il viceversa.

E’ spesso usato in abbinamento al comando default-metric, necessario per specificare il costo delle route da ridistribuire.

redistribute static

Ridistribuisce all’interno del protocollo di routing in esame tutte le sue route statiche.

redistribute connected

Ridistribuisce le route che vengono create automaticamente per il fatto di avere una interfaccia in esse:

  • le route interessate da questo comando sono quelle non specificare da un esplicito comando network

  • per OSPF e IS-IS queste route sono ridistribuite come appartenenti all’esterno dell’AS.

Comandi comuni ai vari protocolli di routing

router proto [ID]

Abilita il protocollo di routing specificato; entra in modalità di configurazione di tale protocollo; ha modalità leggermente diverse per ogni protocollo.

network indirizzo_di_rete

Specifica le reti (direttamente connesse al router) che sono nel dominio di routing in esame (e che verranno annunciate dal protocollo); il router automaticamente capisce quali sono le sue interfacce interessate dal dominio, ed abilita l’invio e le ricezione di messaggi di updates attraverso quelle interfacce. La sintassi del comando è leggermente diversa in OSPF e in BGP.

passive-interface interfaccia

Inibisce l’invio di messaggi di update sull’interfaccia (che, ad esempio, è al bordo del dominio di routing). Può essere una ragione amministrativa (evitare di propagare messaggi in una specifica direzione) oppure economica (impedire la generazione di messaggi di routing su linee commutate quali ISDN).

default-metric metrics

Comando abbinato al redistribute, indicando che tutte le route apprese dall’esterno sono da ridistribuire con metrica metrics; ha modalità leggermente diverse per ogni protocollo.

Comandi specifici per ogni protocollo

RIP

router rip

Abilita il protocollo di routing RIP.

version 1 | 2

Abilita l’invio di messaggi secondo la versione 1 o 2 (default 1); nella ricezione capisce ambedue le versioni.

neighbor indirizzo

Indica al router di inviare i messaggi RIP non solo in broadcast, ma anche all’indirizzo indirizzo specificato; è usato su reti senza capacità broadcast oppure per prevenire l’invio dei messaggi di aggiornamento a specifici routers (ad esempio su LAN in congiunzione al comando passive-interface, per abilitare solo specifici neighbors, per ragioni di policy).

Esempio:

interface Ethernet 0

ip address 128.99.1.8 255.255.255.0

exit

router rip

passive interface Ethernet0

network 128.99.1.0

neighbor 128.99.1.11

end

default-metric metric

Comando abbinato al redistribute, indicando che tutte le route apprese dall’esterno sono da redistribuire con metrica metric (in questo caso un numero).

Esempio di configurazione:

  • aggrega più reti (le 129.99.x.x) in un’unica entry

  • evita l’invio degli annunci sull’interfaccia ISDN, ponendola passiva

interface Ethernet 0

ip address 128.99.1.8 255.255.255.0

exit

interface Ethernet 1

ip address 128.99.3.8 255.255.255.0

exit

interface Bri 0

ip address 128.99.9.15 255.255.255.0

exit

interface Serial 0

ip address 192.31.7.22 255.255.255.0

exit

router rip

version 2

network 128.99.0.0

network 192.31.7.0

passive-interface Bri0

end

IGRP –

EIGRP

router igrp process_id

router eigrp process_id

Attiva il processo di routing.

  • process_id: identifica il particolare processo di routing in esecuzione, che deve essere uguale in tutti i router del dominio IGRP/EIGRP in quanto l’informazione viene inclusa negli annunci. Se si è in un AS registrato è buona norma porre questo identificativo pari al numero dell’AS; nel caso si voglia impiegare contemporaneamente IGRP e EIGRP (per esempio per necessità di transizione), IGRP e EIGRP possono scambiarsi informazioni solo se process_id = AS.

default-metric k1 k2 k3 k4 k5

Comando abbinato al redistribute, indicando che tutte le route apprese dall’esterno sono da redistribuire con metrica indicata.

  • Esempio: default-metric 10000 100 255 1 1500

  • Significato dei termini: banda, ritardo, affidabilità, carico, MTU

metric weights tos k1 k2 k3 k4 k5

Cambia il valore dei parametri utilizzati per il calcolo del costo per uno specifico codice Tipe Of Service (anche se è fortemente sconsigliato cambiarli); il significato dei termini è analogo al comando default-metric.

  • Valori di default: tos: 0, k1=k3= 1, k2=k4=k5= 0.

no metric holddown

(solo IGRP)

Disabilita l’algoritmo di hold down di IGRP, migliorando il tempo di convergenza a scapito di possibilità di loop.

show ip eigrp interfaces

show ip eigrp neighbors

show ip eigrp topology

show ip eigrp traffic

(solo EIGRP)

Comandi di controllo del funzionamento del processo EIGRP.

Esempio di configurazione

interface Ethernet 0

ip address 128.99.1.6 255.255.255.0

exit

interface Ethernet 1

ip address 128.99.3.12 255.255.255.0

exit

interface Bri 0

ip address 128.99.9.4 255.255.255.0

exit

interface Serial 0

ip address 192.31.7.4 255.255.255.0

exit

router EIGRP 143

passive-interface Bri 0

network 128.99.0.0

network 192.31.7.0

end

OSPF

router ospf process_id

Abilita un processo di routing OSPF:

  • process_id: identifica il processo di routing OSPF all’interno del router ed ha significato locale (non viene trasmesso all’esterno del router)

network indirizzo maschera area id_area

La coppia <indirizzo,maschera> individua una o più interfacce che si trovano nell’area id_area sulle quali vengono inviati e ricevuti i messaggi OSPF; OSPF annuncia le reti corrisponenti.

  • maschera è di tipo wildcard (opposta alla netmask IP), dove

    • un bit a 0 identifica la parte di rete

    • un bit a 1 identifica la parte host

  • id_area è codificato su 4 byte, ed è possibile utilizzare sia la notazione decimale che quella decimale puntata.

area id_area stub

Dichiara l’area id_area una stub area.

area id_area range indirizzo maschera

Specifica un address range da annunciare all’esterno dell’area id_area, consentendo l’aggregazione di informazioni per la propagazione all’esterno dell’area id_area (se all’interno dell’area c’è almeno un’interfaccia con l’indirizzo che cade all’interno dell’address range, all’esterno è annunciato l’address range invece dei singoli indirizzi).

area id_area virtual-link ID_router

Crea un link virtuale con il router che ha ID_router, dove questo valore è individuabile visualizzando i database di OSPF; l’area id_area è comune ai due router.

default-information originate [always]

Abilita il router di annunciare una route di default all’interno del suo dominio OSPF, comportandosi da AS Boundary Router (lo stesso scopo può essere ottenuto con il redistribute). Un AS boundary router non annuncia necessariamente la route di default, in quanto potrebbe annunciare più route esterne imparate da altri protocolli.

Se il router non ha alcuna route di default, questo comando è ininfluente, a meno che si specifichi la keyword always, nel qual caso viene comunque sempre immessa una route di default in quel dominio, anche se il router non ne ha una propria.

show ip ospf database

Mostra il database di link state advertisement ricevuti.

sh ip ospf neighbor

Visualizza tutti i router OSPF adiacenti, indipendentemente dall’area a cui appartengono; il campo neighbor_ID mostra l’identificativo (router_ID) del router remoto.

Esempio di configurazione

interface Ethernet 0

ip address 128.99.1.6 255.255.255.0

exit

interface Ethernet 1

ip address 128.99.3.6 255.255.255.0

exit

interface Bri 0

ip address 128.99.119.8 255.255.255.0

exit

interface Serial 0

ip address 192.31.177.12 255.255.255.0

exit

interface Serial 1

ip address 128.99.27.12 255.255.255.0

exit

router OSPF 1

passive-interface Bri 0

network 128.99.1.0 0.0.15.255 area 1

network 128.99.27.12 0.0.0.255 area 1

network 192.31.177.0 0.0.0.255 area 0

network 128.99.119.0 0.0.0.255 area 2

area 1 range 128.99.0.0 0.0.31.255

end

BGP

router bgp AS

Attiva il processo di routing BGP nell’Autonomous System AS.

La configurazione del BGP è leggermente più complessa degli altri protocolli in quanto, oltre alla configurazione delle reti, è necessario procedere alla configurazione manuale dei neighbors.

network indirizzo mask netmask

Identifica questa rete come appartenente al dominio BGP locale e la inserisce nella propria routing table. Il significato è diverso dai protocolli IGP in quanto il comando network non definisce le interfacce sulle quali bisogna inviare gli annunci.

neighbor indirizzo remote-as AS

Dichiara come peer (neighbor) il router indirizzo dell’Autonomous System AS. I neighbor possono essere Internal o External:

  • External: normalmente il router condivide un link con questo peer

  • Internal: è normalmente posizionato in un qualsiasi posto dell’AS.

aggregate-address indirizzo maschera

Se esiste almeno una route per una rete che rientra nel range di indirizzi (indirizzo, maschera) BGP annuncia questo range

Esempio di configurazione

interface Ethernet0

ip address 131.108.1.6 255.255.255.0

exit

interface Ethernet1

ip address 192.31.7.6 255.255.255.0

exit

interface Bri0

ip address 128.99.119.8 255.255.255.0

exit

router bgp 109

network 131.108.1.0

network 192.31.7.0

neighbor 131.108.200.1 remote-as 167

neighbor 131.108.234.2 remote-as 109

neighbor 150.136.64.19 remote-as 99

end